“The element is not found” error when issuing a smart card with XID 8300 printer
Posted by Mikhail Yakovlev, Last modified by Mikhail Yakovlev on 23 February 2019 12:34 PM

Description:
Smart cards are issued using XID 8300 printer.

Problem:
The following error occurs while issuing a device in Indeed CM:


Cause:
Reader names specified in the registry differ from ones of actually connected devices.

Example:
Connected readers:

  1. Contact - USB CCID Smart Card Reader 0
  2. Proximity - HID OMNIKEY 5427 CK CL0

Readers defined in the registry:

  1. The OMNIKEY AG Smart Card Reader USB 0 value is specified in the ContactReaderName parameter of contact reader.
  2. The HID OMNIKEY 5427 CK CL 0 value is specified in the СontactlessReaderName parameter of proximity reader.

As the example shows, the name of connected contact reader  USB CCID Smart Card Reader 0 does not correspond to one defined in the registry parameter ContactReaderName = OMNIKEY AG Smart Card Reader USB 0. This causes the error.

Solution:
Use the listreaders.exe utility, that shows the list of connected readers. To do so, run the CMD application as administrator and execute listreaders.exe command.

The default reader names are:

  1. Contact reader XID 8300 - OMNIKEY AG Smart Card Reader USB 0or USB CCID Smart Card Reader 0
  2. Proximity reader XID 8300 - HID OMNIKEY 5427 CK CL 0

Important: The actual reader names might differ from the default ones.

Run RegEdit.exe and switch to the following registry branch:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\IndeedCM\Client\Printers\XID 8300 (DS)] - for x64

or

[HKEY_LOCAL_MACHINE\SOFTWARE\IndeedCM\Client\Printers\XID 8300 (DS)] - for x86

  1. The ContactReaderNameparameter value should coincide with the name of connected contact reader.
  2. The value of СontactlessReaderName should coincide with the name of connected proximity reader.
(0 vote(s))
Helpful
Not helpful