AirKey issue error in Self Service within RDP session

Created by Mikhail Baturinskiy, Modified on Tue, 15 Apr at 8:50 AM by Mikhail Baturinskiy

Problem:
An error occurs when attempting to issue a card:

Failed to connect an AirKey card
Timeout

However, a card can be successfully issued via management console (icm application) within RDP session from the same workstation.

Cause:
An AirKey card cannot be issued via Self Service when connected via RDP. This happens due to some features of using smart cards in terminal sessions: you have to connect a card somewhere to forward it via RDP. With hardware card, it can be a USB port of hardware workstation. But AirKey card is created exactly at the moment of issuance. And Indeed СМ servers waits for a token to be connected to the workstation and forwarded via RDP. But this is not possible, since the created virtual token is beyond this RDP session.

However, an AirKey can be issued via administrator console (icm) within RDP session, since Middleware is not used in this case: the card is issued on the AirKey server and PCs are added to the card without physical connection to a workstation.

Solution:
To issue an AirKey via Self Service, you have to use a local session on a workstation with AirKey Runtime and AirKey Middleware installed. If it is necessary to issue an AirKey from a virtual or remote workstation via Self Service, then you have to use TeamViewer or similar tool to connect to that workstation.

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article